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Symptom


You are unable to reactivate your CDP Server Product Key after it goes "Invalid." Your Product license key stops working because it has too many failed attempts contacting the CDP Licensing Server.

Example: Exception occurred while contacting R1Soft Server Failed to create output stream: Connection refused

Cause


The CDP Server connects to our License Server: activation.r1soft.com over the Internet on TCP port 443 and uses XML-RPC over HTTPS to activate Product Keys and do periodic checks for Pool keys. A firewall or host based firewall (e.g. iptables) can block ports and keep the CDP Server from connecting to the licensing server on port 443. If your CDP Server does not have Internet access it will not be able connect to the licensing server, please contact your Account Manager for assistance with this scenario and the use of Perpetual Keys.

Perpetual License Key: Does not need to connect to the licensing server at any time during registration to activate the key. Specific requirements must be met to obtain this type of key, contact your account manager.

Pool License Key: Must always have access to the licensing server. If the CDP Server fails to connect to the licensing server after approximately one day of failed connects, the CDP Server will no longer function.

Resolution


Does your CDP Server have Internet access? If the answer is no and you have purchased Pool license keys, you will need to connect the CDP Server to the Internet to activate the keys or upgrade your license with more Agents or Add-ons.  You will need Internet access to use and maintain a CDP Server Pool license Product Key.

If your CDP Server has internet access check and make sure you can ping 'activation.r1soft.com' from your CDP Server command console.  If you cannot ping 'activation.r1soft.com' check your network connection or settings. Also keep in mind that 'ping' (ICMP) does not use a port, so performing a ping test is a very simple test to prove network connectivity. Ping does not test any port usage, 'telnet' can be used for that.

If you can ping activation.r1soft.com from your CDP Server and still have problems activating license keys you may have a firewall blocking access to activation.r1soft.com.  To check for this, try to telnet from your CDP Server to activation.r1soft.com port 443. Do you get a connection? If not, please check and adjust or temporarily disable your firewall and verify you can get there through port 443. Note: in Windows Server telnet can easily be installed as a Feature and it is recommended to remove telnet when finished.

# telnet activation.r1soft.com 443 Example return output: [root@CDP-SRV-120 ~]# telnet activation.r1soft.com 443 Trying 198.64.248.233... Connected to activation.r1soft.com. Escape character is '^]'.

Related Articles


Page: Activating License Keys - Access to Licensing Server from CDP Server (Ports And Firewalls) (Knowledge Base) Labels: license_key, product_key, pool, perpetual, activation
Page: Activating License Keys - Access to Licensing Server from CDP Server (Ports And Firewalls) (Knowledge Base) Labels: license_key, product_key, pool, perpetual, activation
Page: Activating License Keys - Access to Licensing Server from CDP Server (Ports And Firewalls) (Knowledge Base) Labels: license_key, product_key, pool, perpetual, activation
Page: Activating License Keys - Access to Licensing Server from CDP Server (Ports And Firewalls) (Knowledge Base) Labels: license_key, product_key, pool, perpetual, activation
Page: Activating License Keys - Access to Licensing Server from CDP Server (Ports And Firewalls) (Knowledge Base) Labels: license_key, product_key, pool, perpetual, activation
Labels:
license_key license_key Delete
product_key product_key Delete
pool pool Delete
perpetual perpetual Delete
activation activation Delete
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